记一次Firefox降级

因为 firefox quantum 的发布,目前很多插件都未更新到支持firefox quantum。
然后因为开启了firefox的自动更新,插件的自动更新也设置为默认。
就对自己使用造成了困扰。
1,Firebug不支持新版本firefox,同时停止维护了,目前无法正常使用。
2,adblock-plus 更新了版本,过滤元素变得更严格,一些正常的图标都被屏蔽了,只能关闭插件,但插件,广告又出来了。
3,实用功能block the frame没有了。

现需要降级到低版本。
先后试了56和55都无法解决。

最后回到了52版本。

以关键字firefox xx offline installer可以找到下载地址

56版
https://ftp.mozilla.org/pub/firefox/releases/56.0/win64/en-US/Firefox%20Setup%2056.0.exe
55版
https://download-installer.cdn.mozilla.net/pub/firefox/releases/55.0/win64/en-ZA/Firefox%20Setup%2055.0.exe
52版
https://download-installer.cdn.mozilla.net/pub/firefox/releases/52.0.2/win64/en-US/Firefox%20Setup%2052.0.2.exe

关于插件

在可以这里找历史版本下载安装

Firebug 版本历史

adblock-plus 版本历史

google-no-tracking-url

比较良心的是还提供历史版本下载。

关于用户配置文件的备份

参考
[从旧的配置文档中恢复重要数据]
https://support.mozilla.org/zh-CN/kb/%E4%BB%8E%E6%97%A7%E7%9A%84%E9%85%8D%E7%BD%AE%E6%96%87%E6%A1%A3%E4%B8%AD%E6%81%A2%E5%A4%8D%E9%87%8D%E8%A6%81%E6%95%B0%E6%8D%AE

备份主要找到配置文件
在浏览器中输入about:support,然后找到profile folder,选Open Folder

主要用的插件备份

  • Adblock Plus 2.7.3
  • Element Hiding Helper for Adblock Plus 1.4
  • Firebug 2.0.18
  • FoxyProxy Standard 4.6.5
  • Google Redirects Fixer 2.1.0
  • VimFx 0.20.11
  • ScrapBook Plus 1.10.25.42

注意要关闭插件的自动更新。